Is there really a PLUNGE_RATE_MOVE post variable?

Discussion of post processors for various CNC machines

Is there really a PLUNGE_RATE_MOVE post variable?

Postby cnczane » Fri May 29, 2015 3:49 pm

I've been experimenting with the .con file in [MESHCAMDIR]\posts\, and am stymystified by PLUNGE_RATE_MOVE, having seen it in the user manual, and included in a Tormach post (as in post-processor file) which Randy submitted in a post (as in forum post) here.
http://grzforum.com/viewtopic.php?f=8&t ... 2948#p2948
http://www.grzsoftware.com/manual/statements.htm

I copied Randy's syntax, and added a comment, so I could see if it showed up in the output; the line in the .con file is:
PLUNGE_RATE_MOVE = "[N] G1 [Z] [FP] (hello, mother)"
which however does not result in any lines with "mother" in the g-code output.

I also, because I'm using Linux and it's just trivial to do, ran a 'strings' dump of meshcam.exe (both v5 and v6) and hunted for "PLUNGE" in the output. Although all the other varnames named in the manual appear, PLUNGE_RATE_MOVE does not.
(% strings meshcam.exe | less, and then in less hunt for (using the '/' character); e.g., _RATE_, which will take you to a section of the code with a whole meadow full of varnames such as are mentioned in the manual)

So it leaves me wondering if it's, really, "in there." :^)

Cheers!
--
David, the CNCz'
If you have not received a reply from me in over a year, I am not ignoing you: more likely I am fallen asleep under a tree. Again. Please poke me if you think it worth your trouble.
cnczane
 
Posts: 277
Joined: Sun Sep 21, 2008 4:15 am

Re: Is there really a PLUNGE_RATE_MOVE post variable?

Postby Gerry » Sat Jul 11, 2015 12:46 am

No, I don't think so. See this thread:
viewtopic.php?f=8&t=791
Gerry
 
Posts: 198
Joined: Thu May 15, 2008 2:21 am


Return to Post Processors