Include / Exclude Region DXF Issue [my issue may affect you]

General MeshCAM Questions

Include / Exclude Region DXF Issue [my issue may affect you]

Postby larynx » Thu Jun 01, 2017 10:47 pm

In case anyone has used include exclude region DXFs and had a calculation fail I discovered something today that never has happened to me previously. I use include/exclude DXF files almost exclusively with each drawing. It enables me to to load the master STL file, then calculate one bit, then the other, then........ and I love this feature [still not in V7 BETA as of 4, but I can't think Rob will leave it out of the next program update]. Cutting slots and holes, some surfacing and then final shape perimeter cut outs works great for me using different bits and therefore different MeshCAM output files. I never move my piece - just change bits, zero, load the next file and continue. I am stone-age to those of you with auto bit changers.

Anyway, moving on, I had a large file that kept failing to finish and Windows would give me the error that MeshCAM had stopped responding and the only option given was to close MeshCAM. I have seen not responding while there is a lot of processor overhead - but this was not a pause - this was a complete fail. I loaded the STL along with several very large DXF files consisting of hundreds of exclude and include regions. Funny thing, I had created two of these files CAD files with only a very minor change to one [basically many objects cut from blocks, the two files were duplicates with the exception of one object] and the first ran fine, the second kept failing.

So after exhausting trial MeshCAM runs using the individual files of the failed on, with NO failures, but fails when they were all used together, I went back to CAD and found that the one differing object DXF region surface exclude still had the create surface lines attached. So I deleted the two closed rectangular lines and viola - it ran fine.

The final g-code file ended up encompassing 498,103 lines of g-code, and since I never had this hiccup before I thought I would just pass it along, in case anyone else has any issues. Perhaps just check your DXF for other than surfaces.

There may be something elsewhere on the forum about this, I did not find anything, so passing this along for what it is worth - if anything.
I am not aligned with nor do I have any relationship with MeshCAM or its staff other than being a user [that sounds a little like I have a dependency problem]
larynx
 
Posts: 69
Joined: Thu Oct 29, 2015 2:56 am
Location: East Central Florida

Return to General

cron